Interruptions with Disclosure Package Downloads
Incident Report for Floify
Postmortem

Floify Service Interruption January 19, 2024

This incident report details the Floify interruption of service that occurred on January 19, 2024.

Issue Summary

From 11:30 AM MT Jan 19 to 7:30 AM MT Jan 20, Floify experienced a partial interruption of service impacting disclosures. Disclosures were not able to be downloaded and therefore could not be added to the loan pipeline and further, signed and completed. The root cause was due to a code release at 3:00 AM MT on Jan 19 that impacted the disclosure functionality.

Timeline (all times in Mountain Time)

  • 3:00 AM Jan 19 – Floify code was deployed to Production
  • 11:30 AM Jan 19 – Errors specific to disclosure downloads were identified 
  • 11:42 AM Jan 19 – Floify engineers were notified and began their investigation into the issue.
  • 5:30 PM Jan 19 - Floify engineers addressed the issue in the code, and the QA team initiated testing.
  • 6:13 AM Jan 20  – A code fix was deployed to Production. This addressed the disclosure download issues. 
  • 6:34 AM Jan 20 - A database update was used to retry the failed disclosure downloads. 

Root Cause

The root cause of this issue was a code fix that affected the functionality between the Floify App and the Floify eSign Service regarding co-mortgagors specifically when creating disclosure signing documents.

Resolution and Recovery

  • The issue was resolved by completing a code release that resolved the issue. 
  • After the code fix release and testing was completed, a database update was used to retry the failed disclosure downloads. 

Corrective and Preventative Measures

The following are actions we are taking to address the underlying causes of the issue and to help prevent recurrence and improve response times:

Short term:

  • Database updates were used to correct failed disclosure downloads.

Long term:

  • The quality assurance team will persist in developing automated test cases to conduct thorough testing before the release.

Floify is committed to continually adapting and improving our technology and process to prevent service interruptions. We appreciate your patience and again apologize for the impact of this interruption of service. We thank you for your business and continued support.

Sincerely,

The Floify Team

Posted Jan 23, 2024 - 18:29 EST

Resolved
This incident has been resolved.
Posted Jan 20, 2024 - 09:13 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2024 - 08:18 EST
Identified
We've identified interruptions with disclosure packages being downloaded and our developers are currently testing a fix.

We will update this page as we have more information.
Posted Jan 19, 2024 - 18:59 EST
This incident affected: System.