MFA SMS Delay
Incident Report for Floify
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 13:35 EDT
Monitoring
Twilio, SMS service provider, has identified delays in SMS outgoing traffic. We will update our status page once Twilio has resolved this issue. More details from Twilio can be found here: https://status.twilio.com/
Posted Mar 26, 2024 - 10:03 EDT