Disclosures unable to be downloaded
Incident Report for Floify
Resolved
This incident has been resolved and all impacted disclosures have been processed.
Posted Feb 15, 2024 - 12:02 EST
Identified
We've identified an issue with downloading disclosure files. The root cause has been identified, and we are working to deploy the necessary changes to resolve the issue.
Posted Feb 15, 2024 - 11:23 EST
This incident affected: System.