Milestone Delivery Issues

Incident Report for Floify

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 17:24 MDT

Monitoring

A fix has been implemented and we are monitoring notification delivery.
Posted Aug 20, 2026 - 16:41 MDT

Identified

We have identified the issue and are working to implement a resolution.
Posted Aug 20, 2026 - 13:21 MDT

Investigating

We are investigating reports that LOS-synced milestone notification settings may not be honored in some cases, resulting in milestone emails being sent when email notifications are disabled.

Our team is actively investigating the issue and working to identify the scope and resolution. We will provide updates as more information becomes available.
Posted Aug 20, 2026 - 11:33 MDT
This incident affected: Communication Tools (Email Services).