Users are experiencing issues with submitting disclosure documents
Incident Report for Floify
Postmortem

Issue Summary

From 3:00am to 12:07pm MT, Floify experienced a partial system outage, leading to users being unable to submit disclosures and encountering user access errors. The root cause was due to a code release which was scheduled in the daily system refresh.

Timeline (all times in Mountain Time)

  • 3:00 AM - Code was deployed with the daily automatic system refresh.
  • 8:05 AM - Users reported errors when attempting to submit disclosures and inadvertently were logged out of the system.
  • 8:10 AM - Floify engineers were notified and began their investigation into the issue.
  • 11:40 AM - Floify engineers identified the root cause of the issue and began to rollback the code.
  • 12:07 PM - The rollback was completed and the issue was resolved. 

Root Cause

The root cause was determined to be an issue with the code released at 3:00am. Due to this, user sessions were incorrectly handled and some users who were attempting to e-sign were incorrectly logged out.

Resolution and Recovery

This issue was resolved by following internal protocols by reverting to the application instance prior to the 3:00am refresh.

Corrective and Preventative Measures

The following are actions we are taking to address the underlying causes of the issue and to help prevent recurrence and improve response times:

Short term:

  • Rollback application instance to prevent further issues (completed) 

Long term:

  • The quality assurance team will persist in developing automated test cases to conduct thorough testing before the release.

Floify is dedicated to continuously adapting and enhancing our technology and processes to prevent service interruptions. We sincerely appreciate your patience and apologize for the impact of this outage. Your business and ongoing support are greatly valued.

Sincerely,

The Floify Team

Posted Feb 23, 2024 - 14:42 EST

Resolved
This issue has been resolved and a root cause analysis will be posted shortly.
Posted Feb 22, 2024 - 14:11 EST
Investigating
We are currently investigating an issue with submission of disclosure documents.
Posted Feb 22, 2024 - 13:06 EST
This incident affected: System.